Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Epijano

Wie erreiche ich mein Raspberry Pi aus dem Internet

Hi,

ich versuche inzwischen seit einigen Tagen mein Raspberry Pi aus dem Internet zu erreichen. Leider mit relativ geringem Erfolg. Ich habe an meiner Connect Box eine Portweiterleitung eingerichtet. Trotzdem ist die globale IPv6 Adresse des Raspberrys nicht von ausserhalb meines Heimnetzes erreichbar.

Das Aufrufen von http://www.ipv6-test.com/ liefert mir die Information, dass IPv6 bei mir nicht unterstützt wird (Bild 1). Auch im Statusfenster meiner Netzwerkkarte steht, dass ich derzeit keine Netzwerkverbindung via IPv6 habe(Bild 2). Wie kann das sein, wenn die Connect Box eigentlich nur IPv6 unterstützt?

Gruß

Jan
Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
Dieser Beitrag wurde geschlossen.
Es ist nicht möglich, Kommentare zu schreiben. Du kannst aber jederzeit eine Frage stellen.
Frage stellen
6 Kommentare
2018-02-19T11:30:47Z
  • Montag, 19.02.2018 um 12:30 Uhr
Zunächst einmal wird es in absehbarer Zeit keine Router geben, die KEIN IPv4 unterstützen.
Sonst würden alle mit IPv6/DS-Lite nicht auf diese Seite zugreifen können.

Dass ein Gerät IPv6 unterstützt, heisst nicht automatisch, dass es auch eine bekommt.
Du bist übrigens der Erste, der sich darüber beschwert.

Du bist offensichtlich ein Altkunde aus BaWü.
Hier hast du die Möglichkeit, echtes DualStack über den Support zu bekommen.
Leider sind die bequemen Wege über Facebook/Twitter inzwischen geschlossen.
Telefonisch würde ich das auf keinen Fall probieren, da du sonst womöglich ein Fall für die Klappsmühle wirst.
Auf der Kontaktseite gibt es unten manchmal ein Chat-Icon (bitte nicht mit UBO verwechseln), das angeblich besser sein soll. Ich habe dazu keine Erfahrungen.
Wenn du Pech hast, bekommst anstatt DualStack IPv6/DS-Lite. Ich würde es mir in der jetztigen Situation wirklich überlegen, ob ich mir IPv6 antun möchte, wenn ich es nicht wirklich brauche.

P.s. Über IPv4 sollte es eigentlich tun. Je nach Router sind dort aber andere Details einzustellen.
Wenn du am Router wirklich eine globale IPv6 hast, hast du irgendwas in deinem Netz, das nur über IPv4 funktioniert (z.B. ein weiterer Router, der falsch konfiguriert ist)
2018-02-19T15:14:06Z
  • Montag, 19.02.2018 um 16:14 Uhr
@Epijano

Steht an Deiner Connect Box irgendeine Status/Online-Meldung bezüglich IPv6/DS-lite, AFTR-Gateways o.ä.?

Das wäre die Voraussetzung damit die Vernetzung des Raspberry Pi mit IPv6 überhaupt funktionieren kann.

Wenn in der Connectbox alles i.O. scheint, stellt sich natürlich die Frage, warum Dein Windows-Rechner kein IPv6 nutzt. Da Du aber den Raspi vernetzen möchtest, ist das erstmal zweitrangig.
Was sagt denn der Befehl "ip -6 a" auf der Konsole des Raspi?
Sind da IPv6-Adressen zu sehen, mehr als nur "fe80...."?

@Plumper, nach IPv4 wurde nicht gefragt, warum Du dann Epijano etwas aufschwatzen willst, was sowieso nur noch schwer zu bekommen ist, ist mir ein Rätsel
2018-02-19T16:15:44Z
  • Montag, 19.02.2018 um 17:15 Uhr
Vielen Dank für eure Antworten. Ich denke ich fang erst jetzt an so wirklich zu verstehen was mein Problem ist. Ob IPv4 oder IPv6 ist mir zunächst einmal egal. Mein Problem war, dass ich versucht habe über IPv6 Nachrichten an ein Raspberry zu schicken, dass an einem Router mit IPv4 Adresse hängt(sowas kann ja gar nicht funktionieren). Ansonsten hatte ich auch nicht verstanden warum die Connect Box bei den Einstellungen für die Portweiterleitung nach IPv6 Adressen fragt wenn die Adresse des Routers zum Internet hin eine IPv4 Adresse ist. Das ist ja aber eigendlich gar kein Widerspruch. Innerhalb meines Heimnetzes darf es ja durchaus IPv6 Adressen geben. Das hindert den Router vermutlich (hoffentlich:grin nicht an der Weiterleitung. Mein Raspberry Pi hat nämlich eine IPv6 Adresse mit der ich auch Seiten im Browser öffenen kann.
Das Problem das ich im Moment noch sehe ist, dass sich meine v4 Netzadresse ja immer mal wieder ändert und ich in der Connect Box keine Einstellungen gefunden habe um einem DNS Server die aktuelle Adresse mitzuteilen. Da sollte es aber Lösungen geben mit denen das auch mit dem Pi zu bewerkstelligen ist.

Bin leider erst wieder am Wochenende daheim und werde frühestens Freitag ausprobieren obs mit der IPv4 funktioniert.

@thomasschaefer
Eine Status/Online-Meldung bezüglich IPv6/DS-lite, AFTR-Gateways o.ä. hab ich bei mir nicht gefunden. Mein Raspberry Pi hatte allerdings funktionierende IPv6 Adressen.

An und für sich hab ich nichts gegen die IPv4 Adresse. Vielleicht bin ich aber auch einfach noch nicht an dem Punkt an dem ich eine v6 Adresse für meine Anwendungen brauche. Ich versuchs am Wochenende mal mit v4 und den neuen Erkenntnissen und wenn das nicht funktioniert frag ich nach DS-lite.
2018-02-19T19:06:33Z
  • Montag, 19.02.2018 um 20:06 Uhr
DS-Lite wirst du einfach bekommen. Nur was tust du, wenn du es damit nicht gebacken bekommst?
Du brauchst dazu z.B. auch außen IPv6, sonst kann das nichts werden.

In BaWü kannst du DualStack erhalten. Das ist eine vollständige IPv4 UND IPv6.
Hast du eigentlich über einen fremden Provider, z.B. Mobilnetz, getestet. Im eigenen Netz funktioniert es regelmäßig nicht.
Dass du bei aktiver IPv6 eine FE80 bekommst, ist normal. Die nennt man Linklocal.
Eine öffentliche IPv6 beginnt beim alten Kabelbw mit 2a02.
2018-02-20T20:58:13Z
  • Dienstag, 20.02.2018 um 21:58 Uhr
Ich habe ohne Erfolg versucht das Raspberry mit seiner globalen IPv6 Adresse vom Mobilnetz aus anzupingen. Das hat natürlich nicht funktioniert. Im eigenen Netz habe ich bei einem Ping an die IPv6 Adresse des Pi's immer eine Antwort bekommen. Ich konnte aus meinem Heimnetz heraus auch ohne Probleme die Apache2 Server Testseite im Browser aufrufen.
Der ifconfig Befehl hatte ergeben, dass mein Pi eine v4 und zwei v6 Adressen besitzt. Die globale v6 Adresse fängt tatsächlich mit 2a02 an.
2018-02-23T20:10:13Z
  • Freitag, 23.02.2018 um 21:10 Uhr
Okay. Habe gerade ausprobiert über die IPv4 meines Routers die Apache Testseite aufzurufen und bin wieder gescheitert.
Folgende Seite zeigt mir an, dass meine Ports geschlossen sind: http://www.dnstools.ch/port-scanner.html. Muss ich da ausser der Portweiterleitung noch etwas einstellen?

@Plumber
Du hattest gemeint ich könne in Baden Württember Dual Stack erhalten. Wäre das dann mit Mehrkosten verbunden oder reicht es den richtigen Supportmitarbeiter zu erwischen?