Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Dill

Unitymedia DNS Server unzuverlässig

Hallo Comunity,

seit vielen Tagen hatte ich häufig Probleme mit dem Seitenaufbau vieler Seiten. Ständig kam die Browsermeldung "Seite nicht erreichbar" und erst mit dem zweiten oder dritten Laden konnte sie dann dargestelt werden. Oft dann auch nur teilweise.

Nun habe ich mir die Zeit genommen und vieles ausprobiert. Dabei hat sich die Vermutung bestätigt, dass es sich um ein DNS Pronblem handelt.

Das Kuriosum; Ausschließlich die DNS Server von UM, die der Connectbox mitgeteilt werden, sind zu bis zu 50% nicht erreichbar.

--- 2a02:908:2🇦:1 ping6 statistics ---
82 packets transmitted, 44 packets received, 46.3% packet loss
round-trip min/avg/max/std-dev = 10.880/63.378/193.167/62.345 ms

Andere wie Google oder Quad9, funktionieren ohne Probleme.

Da ich den Ping direkt aus der Connectbox absetze, kann ich ein LAN Problem aussließen.

Das würde aber bedeuten, dass mehr Leute das Problem haben dürften.

Der UM Support konnte das nicht bestätigen und schickt mir nun einen Techniker. Ich habe aber große Zweifel, dass der von hier helfen kann.

Hat jemand ähnliche Erfahrungen/Probleme?

Ich habe das nun erstmal so gelöst, dass ich den DNS von Quad9 umgestellt habe. Zum Glück funktioniert der zweite Router hinter der CB, so dass ich das für alle Geräte im DHCP ändern konnte...

Vielleicht kann ja mal der ein oder andere in NRW einen Pingtest machen.
ping6 2a02:908:2🇦:1

Grüße
Dill
Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
Dieser Beitrag wurde geschlossen.
Es ist nicht möglich, Kommentare zu schreiben. Du kannst aber jederzeit eine Frage stellen.
Frage stellen
13 Kommentare
2018-03-17T15:13:33Z
  • Samstag, 17.03.2018 um 16:13 Uhr

Mit namebench den besten DNS-Server ermitteln und im Router einstellen. Problem gelöst.

2018-03-17T16:08:13Z
  • Samstag, 17.03.2018 um 17:08 Uhr

Ja, schon passiert, wie ich bereits schrieb...

Mich würde trotzdem interessieren, ob das Problem auch bei anderen besteht. Bei den vielen Beschwerden über Verbindungsabrüche würde mich das nicht wundern. Mal abgesehen davon, dass nicht viele UM Kunden dazu in der Lage sind, dass für alle ihre Geräte einzeln zu anzupassen (iPhone, Tab, Laptop, etc.). In der CB lässt sich der DNS nicht ändern!

2018-03-18T05:54:35Z
  • Sonntag, 18.03.2018 um 06:54 Uhr
Nein wir haben keine Probleme ,weil der Aftr von Unitymedia ist der schnellste, da hat Namensbench auch nicht viel gebracht.Klar, die Konsterlation kennt ja keiner wieder, da liest man nur wieder zwischen den Zeilen, dass es ist ein zusätzlicher Router angeschlossen wurde. Also auf einem Anschlussport mit IPv4 müssen alle DNS-Anfragen über eine IPv4 Adresse über Ipv6 getunnelt werden.(bzw geroutet,da es kein Bridge-Modus hat)
Statt alle Ports der CB ohne Router zu nutzen(Zum Testen über Lan).Ich kann wetten ,dass noch Windows 10 benutzt wird, evtl. mal Knoppix verwenden. Ist da noch eine Horizonbox im Netz? Ist die auch noch aktiv? Das sind wieder alles so Dinge ,wo Verzögerungen der DNS-Anfragen kommen können(ten) und der größte Teil ist auf der Clientseite zu suchen.
2018-03-19T11:43:09Z
  • Montag, 19.03.2018 um 12:43 Uhr
@Kollege Horst,

Wie ich bereits im Ausgangspost geschrieben habe ('Da ich den Ping direkt aus der Connectbox absetze, kann ich ein LAN Problem aussließen.'), wurde der Test über das Connectbox interne Pingtool abgesetzt.
Ich habe sogar mit einem Netzwerksniffertool (Wireshark) geprüft, ob das Tool nicht nur einfach ein, auf dem lokalen Rechner ausgeführtes Browserscript ist. Ist es nicht! Das bedeutet, dass alle Probleme im Netz hinter der Connectbox rein GARNICHTS mit dem genannten Problem zu tun haben und sämtliche genutzten Betriebssysteme KEINE Rolle spielen!

Wenn du außerdem nochmal genau hinguckst, handelt es sich bei dem Ping Test um eine IPv6 Adresse, nix Tunnel! Und du setzt hier anscheinend AFTR mit DNS gleich...

Abgesehen davon funktioniert mein IP6 Netz mit dem Zweitrouter wunderbar und ich bin aus den genannten Gründen froh drum!

Wenn man auf einen Post antwortet, doch bitte den Ausgangspost vernünftig lesen und nicht gleich von anfang an Dummheit und Unkenntnis unterstellen. Das kann der Firmeneigene Support schon alleine gut genug...
2018-03-19T11:45:58Z
  • Montag, 19.03.2018 um 12:45 Uhr
@ Horst,

Abgesehen davon mag der DNS von UM der schnellste sein (Ja, das behauptet auch namebench bei mir). Wenn der aber bei 50% der Anfragen nicht erreicht wird, helfen mir die anderen 50% auch dann nicht, wenn die 0ms pingtime haben!
2018-03-19T11:56:23Z
  • Montag, 19.03.2018 um 12:56 Uhr
Genau aus den genannten Gründen, ist das ganze ein ziehmlich perfiedes Problem, dass wohl kaum einem wirklich auffällt. DNS Probes funktionieren; Zu mehr als 50% der DNS anfragen funktionieren, weshalb die Seiten aufgebaut werden und keiner auf ein DNS Problem tipt; DNS Benchmarktools zeigen den DNS als schnellsten an, etc. Selbst die Leitungstests des Support und eines Technikers vor Ort zeigen keine Fehler. Nur wenn man explizit die Erreichbarkeit per Ping testet, wird das Problem klar, und wer tut das schon...
2018-03-19T12:03:28Z
  • Montag, 19.03.2018 um 13:03 Uhr
Du kannst Pings nicht für das von dir genannte Szenario zur Fehlereingrenzung benutzen. Eine DNS Abfrage wird sogut wie immer, selbst bei systemweit-ausgeschaltenem DNS Cache in Windows, im Browser, CMD, etc. gecached. Schon beim nächsten Ping in der Reihe würde er die ip > Domain Zuweisung bereits wissen und das DNS erstmal komplett umgehen. Der Paketverlust wird also nicht vom DNS kommen, sondern irgendwo anders auf der Route zum Ziel.
2018-03-19T12:14:59Z
  • Montag, 19.03.2018 um 13:14 Uhr

@ lalaluu

Ok, zum letzten mal, wenn noch einer so einen Sinnlosen Kommentar abgibt, bin ich hier raus!

Eine IP PING Anfrage MUSS zu 100% beantwortet werden können. Ist dies nicht der Fall, gibt es grundsätzliche Probleme mit dem Netzwerk und das völlig unabhängig vom Protokoll (egal ob HTTP, FTPo der DNS). Es gibt da nur wenige Ausnamen, die meist dann auch wegfallen, wenn die Pings nur zum Teil durchkommen!

Wenn eine gecachte adresse vom lokalen Rechner oder vom Router oder sonstwo her geholt wird, gibt es auch kein Problem mit dem Seitenaufbau, denn der DNS wird überhauptnicht direkt angesprochen. Das Problem taucht ja eben genau nur DANN auf, wenn die Daten aktualisiert vom DNS abgerufen werden! Und zum letzten mal; Der Ping geht direkt aus der Connectbox ins Kabelnetz.

Nochmal zum mitmalen der Pingverlauf: Connectbox -> Kabelnetz -> DNS
Und NICHT!!!! Rechner -> WLAN -> anderer Router -> LAN -> Connectbox -> Kablenetz -> DNS

Außerdem habe ich eine IP angepingt und keine Domain (was bei einem DNS Server auch überhaupt keinen Sinn machen würde). Dabei wird NIE eine DNS abfrage durchgeführt! Und das ein PING nichts direkt mit einer DNS abfrage zu tun hat ist mir klar. Aber genauso klar sollte sein, dass eine DNS Abfrage NICHT zuverlässig funktionieren KANN, wenn nichteinmal die PING Pakete zuverlässig durchkommen!

2018-03-19T12:21:36Z
  • Montag, 19.03.2018 um 13:21 Uhr
Dill:

@ lalaluu

Eine PING Anfrage MUSS zu 100% beantwortet werden können. Ist dies nicht der Fall, gibt es grundsätzliche Probleme mit dem Netzwerk und das völlig unabhängig vom Protokoll (egal ob HTTP, FTPo der DNS).



Kompletter Blödsinn. Niemand muss seinen Server per Ping erreichbar machen. Das gehört weder zum guten Ton, noch ist es in irgendeiner RFC so festgelegt. Es ist mittlerweile sogar so, dass viele Gateways und Server einzelne Pings zurückweisen, spätestens wenn mans übertreibt. Probier doch mal die root Server der ICANN bzw. IANA mit Pings zu beschießen. Such dein Problem lieber auf der Traceroute. Mit einem simplen Ping wirst du nie erfahren wo genau auf der Route es zum Problem kommt, das auch mal durchaus des öfteren auf Seite eines großen Carriers liegen kann. Sowas gibt es öfter mal temporär.

Ansonsten möchte ich dich in deinen Monologen nicht weiter stören :D
2018-03-19T12:42:35Z
  • Montag, 19.03.2018 um 13:42 Uhr
lalaluu:
Dill:

@ lalaluu

Eine PING Anfrage MUSS zu 100% beantwortet werden können. Ist dies nicht der Fall, gibt es grundsätzliche Probleme mit dem Netzwerk und das völlig unabhängig vom Protokoll (egal ob HTTP, FTPo der DNS).


Kompletter Blödsinn. Niemand muss seinen Server per Ping erreichbar machen. Das gehört weder zum guten Ton, noch ist es in irgendeiner RFC so festgelegt. Es ist mittlerweile sogar so, dass viele Gateways und Server einzelne Pings zurückweisen wenn mans übertreibt. Probier doch mal die root Server der ICANN bzw. IANA mit Pings zu beschießen. Such dein Problem lieber auf der Traceroute. Mit einem simplen Ping wirst du nie erfahren wo genau auf der Route es zum Problem kommt, das auch mal durchaus des öfteren auf Seite eines großen Carriers liegen kann. Sowas gibt es öfter mal temporär.

Ansonsten möchte ich dich in deinen Monologen nicht weiter stören

Da wiederspreche ich dir ja garnicht, außer in dem Punkt, dass ICMP nach Definition der IP6 Spezifikationen frei zu funktionieren hat, auch wenn sich kaum einer daran hält! Ping flooding ist überhaupt kein Thema mehr und insbesondere DNS Server sollten auf ein Ping blocking verzichten, um eine Problemdiagnose überhaupt zu ermöglichen!

Aber das spielt in diesem Fall überhaupt keine Rolle! Der DNS Server von UM mit der IP6 2a02:908:2a:1 scheint die Pings ja offensichtlich NICHT zu blocken denn jeder zweite wird beantwortet. Ein automatischer Block aufgrund von zu vieler Anfragen ist wohl auch ausgeschlossen, sonst würde meine IP dauerhaft geblockt und nicht nur für 1 oder 2 Sekunden... Mal abgesehen davon, dass es ziehmlich problematisch wäre, wenn ein DNS Pakete dieser Größe schon so schnell blocken würde, denn dann könnte er auch keine DNS anfragen in ausreichender Menge beantworten!

Wie du auf Monolog kommst wundert mich, denn ich kann mich nicht erinnern unter dem Namen lalaluu mir selbst geantwortet zu haben...😜

Meine Intention war es evtl. Usern mit ungelösten Verbindungsproblemen eine weitere option zu nennen. Denn anders als die UM Propagandisten hier scheint es doch für einige ein offensichtlichs Problem zu sein: https://www.unitymediaforum.de/viewtopic.php?f=53&t=36721&p=396988#p396988

Aber was soll ich sagen: Jeder Kunde verdient seinen Provider... Weiterhin viel Spaß mit eurer Leitung...