Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Diese Community verwendet Tracking-Tools Matomo zur Verbesserung des Angebots. Mit Zustimmung hilfst Du uns unsere Seite zu verbessern und akzeptieren unsere Datenschutzerklärung. Vielen Dank!   Erfahren mehr.
Zustimmen Nicht Zustimmen
Denrage

Öffentliche IPv6-Adresse nicht erreichbar

Ich bin seit wenigen Tagen Kunde bei Unitymedia und versuche derzeit einen Windows-Rechner, auf dem ein Apache-Server läuft, übers Internet zu erreichen.
Angeschlossen ist dieser direkt an der Fritz!Box 6490.
Den Router kann ich aus einem anderen Netz anpingen, nur verschwinden die Pakete zum PC irgendwo im Unitymedia-Netz (laut tracert).
Was ich versuchte:
- Windows-Firewall deaktvieren
- IPv6 Freigabe für das Interface komplett abgeschaltet
- Nur bestimmte Ports in der IPv6 Freigabe angegeben
- MyFritz-Freigabe
- Dynamic DNS-Diesnte (dynv6 bzw. ddnss)

Der PC kann ohne Probleme und Einschränkungen ins Internet, nur eben der direkte Zugriff wird mir verweigert. Ich habe auch 2 Freunde, die auch die 6490 besitzen und bei einem funktioniert nichts, so wie bei mir, und beim anderen nur die MyFritz-Freigabe.
Das ich auf das Fritz!Box-Webinterface über die öffentl. IPv6 der Fritz!Box zugreifen, aber nicht über die öffentl. IPv6 des Rechners diesen anpingen kann, glaube ich langsam, dass die IPv6 Freigabe der Fritz!Box nicht ganz richtig funktioniert und einfach alles blockt oder nicht weiß, wohin er es routen soll.

Ich hoffe, mir kann einer weiterhelfen.

Best Regards
Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
Dieser Beitrag wurde geschlossen.
Es ist nicht möglich, Kommentare zu schreiben. Du kannst aber jederzeit eine Frage stellen.
Frage stellen
10 Kommentare
2017-09-08T21:54:31Z
  • Freitag, 08.09.2017 um 23:54 Uhr
Danke für die schnelle Antwort, aber mir ging es nicht um einen VPN und die Problematik von IPv4 und IPv6 und DS-Lite sind mir bekannt. Mein Problem ist das, dass ich von einem IPv6-Gerät aus dem Internet nicht auf die öffentl. IPv6 eines Rechners zugreifen kann, aber auf dessen Router.
2017-09-09T16:02:24Z
  • Samstag, 09.09.2017 um 18:02 Uhr
Weißst du was ich glaube. der Apache -Server muss eine IPv6 Adresse haben.In dem Fall denkst du noch über Ports, statt die öffentliche IPv6+IPV6 des ApacheSevers,du musst direkt den Server ansprechen. Kann das sein?(füher IPv4+Portnummer)
Es gibt Beispiele im Netz von IPv6+Portnummer (z.B 80)VirtualHost..

Statt ein Apacheserver ,kannst du ja mal eine IPV6-Webcam probieren.Teure Webcams haben ei kleines Progrämmchen,die rufen den öflich. IPV6 des angeschlossenen Rechners ab und kombinieren das mit einer HardwareAdresse.(IPv6+Mac) oder haben eine eigene IPv6-Adresse.
Du sprichst bei IPv6 direkt das Gerät an,dh nicht mehr über Ports.Der Rest sind Notlösungen.
Die Fritzbox sollte außen vor bleiben.Wenn die Webcam von der Fritzbox gefiltert wird.dann liegt es an der Box.Aber laut AVM: *Die FRITZ!Box ermöglicht die gleichzeitige Verwendung von IPv6 und IPv4 (Dual Stack-Konzept)* Du hast aber kein Dual-Konzept nur in einer Richtung(DS-Lite?).
IPv6 auf IPv6 sollte funktionieren.

Hier mal Beispiele: https://httpd.apache.org/docs/2.4/de/bind.html Ich kann aber momentan nicht im Internet finden,ob ein Apache rein IPv6 kann.

Hier noch mal zur Fritzbox. 
http://www.pc-magazin.de/news/fritzbox-ipv6-sicherheitsluecke-update-avm-3198060.html

2017-09-09T16:18:33Z
  • Samstag, 09.09.2017 um 18:18 Uhr
Hier noch mal ein Tip: http://serverzeit.de/tutorials/admins-haften

Deswegen habe ich mir so etwas nie selbst aufgebaut,weil ich auch nicht die Zeit habe und das Risiko zu hoch ist.Hier muss man wissen was man macht. Es gibt andere Lösungen.
2017-09-09T17:19:55Z
  • Samstag, 09.09.2017 um 19:19 Uhr
Vielen Dank für die Antworten.
Es geht derzeit nicht mal mehr um einen Apache-Server, sondern um das generelle Problem, dass ich nicht auf einen Computer über seine öffentl. IPv6 mit einem IPv6-fähigem Gerät aus dem Internet auf diesem zugreifen kann. Dies bedeutet, dass nicht einmal ICMP-Pakete bis zum Rechner durchkommen, aber bis zum Router.

Ich muss dich dabei leider korrigieren. Auch IPv6 benutzt weiterhin Ports. Was du meinst, ist das NAT. Dabei "missbraucht" man den Port, um herauszufinden, an welche Netzwerkkarte der Router das Paket routen soll. Da jetzt jede Karte eine eigene IPv6 hat, entäfllt dies natürlich. Der Port wird lediglich für die Firewall genutzt, um bestimmte Protokolle zu blockieren bzw. durchzulassen. Dies bedeutet, dass auf dem Computer, welcher das Paket empfangen soll, der Port weiterhin verwendet wird, um zu wissen, für welche Anwendung das Paket ist (Application Layer(7) OSI-Modell). Somit wird weiterhin IP+Port benutzt.

Du hast ziemlich genau mein Problem auf den Punkt gebracht: IPv6 auf IPv6 sollte eigentlich gehen, aber dies geht eben nicht. Da dies aber ein Routing-Problem ist, stehen Anwendung und Ports komplett außen vor, genauso die Problematik mit DS-Lite, da keine IPv4-Adressen im Spiel sind. Da das Routing bis zum Router einwandfrei funktioniert, glaube ich eben, dass es an diesem liegt und da ich nicht der einzige in meinem Bekanntenkreis bin(, die auch eine FB 6490 benutzen), der diese Problematik besitzt, glaube ich, dass es an dieser liegt

Vielen dank für das Hinweisen auf die Sicherheit. Die Problematik der Fritz!Box ist mir bewusst, da Unitymedia keine Updates seit über einen Jahr mehr zur Verfügung stellt, habe ich mir dafür schon eine andere Lösung überlegt, was aber erst mal nichts hiermit zutun hat.
Auch bin ich mir die Risiken und Gefahren bewusst und ziemlich sicher, dass ich ausreichend Wissen besitze, um mein Vorhaben dementsprechend abzusichern, da solche System nichts neues für mich sind. Dies weicht aber vom eigentlichen Thema ab.
2017-09-09T17:48:20Z
  • Gelöschter Nutzer
  • Samstag, 09.09.2017 um 19:48 Uhr
Bist du sicher, dass du die richtige IPv6 benutzt?
Stichwort z.B. privacy Extensions
2017-09-09T18:32:46Z
  • Samstag, 09.09.2017 um 20:32 Uhr

Privacy Extensions ist ein gutes Stichwort und habe so noch nicht daran gedacht.
Zuerst versuchte ich mit der IPv6-Angabe in IPConfig zu arbeiten (gibt ja eine IPv6 und eine temporäre IPv6, die eben die privacy ist), danach habe ich für Testzwecke Privacy Extension komplett ausgeschaltet, funktioniert aber leider immer noch nicht.

Dabei fiel mir auf, dass sich interessanterweise der Prefix von der IPv6 des PCs mit dem des Routers unterscheidet.
O=gleich X=ungleich

OOOO:OOOO:XXXX:XXXX::

Da der PC aber eig. im Subnet des Routers liegt, müsste er doch den gleichen Routing Prefix nutzen, oder nicht?

2017-09-26T14:30:39Z
  • Dienstag, 26.09.2017 um 16:30 Uhr
Hi Denrag,
Ich habe das gleiche Problem und schon alles mögliche probiert. 
Die FB leitet einfach keine IPv6 Freigaben weiter, egal ob nur ein Port, Ping6 oder komplett offen für den Server danach eingestellt wird.
Ich habe auch so eine doofe FB von Unitymedia mit FW-Version  6.50   
Habe auch schon die Privacy Extensions  auf dem Server deaktiviert (also keine temporäre IPv6 Adresse auf dem Server) und die IPv6 Freigaben neu eingerichtet, bringt alles nichts
Wenn jemand eine Lösung hat,  wäre ich sehr SEHR dankbar!

2018-02-09T15:22:19Z
  • Freitag, 09.02.2018 um 16:22 Uhr

Hab hier die 6360 Fritzbox mit Unitymedia Branding, hab da vor über ne Jahr schon aufgegeben, manchmal ging es dann ging es wieder nicht, kam dann immer Zugriff verboten bei Pings usw, obwohl komplett geöffnet Zielrechner hatte keine Firewall, auch der AVM Support konnte nicht weiterhelfen, sollte da logs hinschicken usw meinte wäre alles korrekt kann nur am Zielrechner liegen.

Ich vermute es liegt einfach an der speziellen Unitymedia Firmware die drauf ist.

Weiss gar nicht was ich schlimmer finde, das es nicht pure Modems gibt oder das man meint  auf die Router ne eigene beschränkte Firmware zu installieren.

2018-02-09T16:21:13Z
  • Freitag, 09.02.2018 um 17:21 Uhr
Und die freigegene IPv6 in der Fritzbox entspricht wirklich der IPv6 auf dem Server?
Das ist ein Problem auch mit aktueller FW bei meinem PI (auf einem Windows-Rechner tut es).

Es gibt keine spezielle UM-Firmware, nur 1 Konfigurationsdatei, die das eine oder andere mehr oder weniger gut verhindert. (z.B. Bridge, eigene Rufnummern)