Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Tigerfun

Aus dem Intranet keine Namensauflösung mehr auf eigene Server

Hallo Community,

ich betreibe in meinem LAN diverse Server, die per xyz123abc.myfritz.net:12345 und Portweiterleitung von aussen aus dem Internet erreichbar sind. So weit so gut.

Bisher war es auch kein Problem, sie mit dieser Adresse auch von innen, also aus dem LAN/WLAN zu erreichen.

Seit der Umstellung auf Cable Max 500 meldet sich unter xyz123abc.myfritz.net:xyz aber nur noch der FritzBox-Log-In, nicht mehr der gewünschte Server. Die FB scheint alles auf sich selbst aufzulösen und ignoriert die Portfreigaben.

Das ist ein ziemliches Drama, weil unter dem lokalen Namen (xyz.fritz.box)  die SSL-Zertifikate natürlich nicht mehr zu URL passen und diverse Server-Probleme auftreten (dynamisch erzeugte Links funktionieren nicht mehr etc).

Was tun?


Vodafone Business CableMax 500, feste IPV4, FRITZ!Box 6490 Cable, FRITZ!OS: 07.10
Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
9 Kommentare
2020-04-06T22:04:54Z
  • Dienstag, 07.04.2020 um 00:04 Uhr
Hey, kann es sein, dass man dich auf DS Lite umgestellt hat?


Schau mal in der Fritte nach, sollte da was von DS Lite stehen hast du deine Antwort.


Sind deine Server via IPV4 direkt erreichbar ohne die MyFritz Adresse?

Warum verwendest du keine eigenen Domains?


Was passiert, wenn du die Server direkt mit der IP ansprichst, klappt die Verbindung?


Sprichst du die Server wirklich von außerhalb mit der Adresse an oder intern?

Stichwort: DNS-Rebind-Schutz..


https://avm.de/service/fritzbox/fritzbox-7590/wissensdatenbank/publication/show/663_DNS-Auflosung-privater-IP-Adressen-nicht-moglich/

2020-04-07T07:49:25Z
  • Dienstag, 07.04.2020 um 09:49 Uhr
Danke für die schnelle Antwort!

>Hey, kann es sein, dass man dich auf DS Lite umgestellt hat?

Ich hoffe nicht.


>Schau mal in der Fritte nach, sollte da was von DS Lite stehen hast du deine Antwort.


Find da nichts, wo sollte das stehen?


>Sind deine Server via IPV4 direkt erreichbar ohne die MyFritz Adresse?


Interne adresse aus dem Intranet: Ja

externe IP-adresse aus dem Intranet: Nein

externe IP-adresse aus dem Internet: Ja


>Warum verwendest du keine eigenen Domains?


Ist für ein Team von Entwicklern, eigene Domains sind überflüssig. Bezweifle auch, dass eine andere Namensauflösung helfen würde, denn die würden ja wieder auf die selbe IP-Adresse verweisen.


Die Namensauflösung seitens myfritz.net funktioniert, weil der Zugriff von anderen PC aus dem Internet ja funktioniert.


(Was zum lachen am Rande: Verwende derzeit ein VPN-Tunnel auf einen anderen PC im Internet, um von dort aus auf meine Server im LAN zuzugreifen. Moderne Zeiten )


> Was passiert, wenn du die Server direkt mit der IP ansprichst, klappt die Verbindung?


Ja, das ist das selbe wie mit dem DHCP-Namen. Geht, aber falscher Servename, falsches SSL-Zertifikat und ungültige Links, da aus externer Sicht.


> Sprichst du die Server wirklich von außerhalb mit der Adresse an oder intern?

> Stichwort: DNS-Rebind-Schutz..


tracert abc.myfritz.net: in 1 hop zu meiner externen IP V4 adresse  b2b-78-x-y-z.unitymedia.biz


>https://avm.de/service/fritzbox/fritzbox-7590/wissensdatenbank/publication/show/663_DNS-Auflosung-privater-IP-Adressen-nicht-moglich/


Das hat bis zum Upgrade immer funktioniert. Jetzt führt die FB keine Portweiterleitung mehr an den vorgesehen Server durch, wenn die Anfrage von innen kommt. Habe noch nie den Rebind-

Schutz verwendet oder gebraucht.


Hm.

2020-04-07T08:01:48Z
  • Dienstag, 07.04.2020 um 10:01 Uhr
Die zweite Geschichte kann noch sein, dass du mit dem Tarifwechsel eine andere Technologie bekommen hast. 
In diesem Fall müsstest du intern irgendwas umstellen.
Das kann dir aber wohl nur die Business-Hotline beantworten.

Die SocialMedia-Kanäle kümmern sich nur um Privatkunden.
2020-04-07T08:20:39Z
  • Dienstag, 07.04.2020 um 10:20 Uhr
Da war ich schon. Die erste Dame hat sich mehrfach glaubwürdig entschuldigt, aber war nicht wirklich zielführend.... Ich bin nicht sicher, ob sie das Problem tatsächlich verstanden hat. Der zweite Versuch ist auch gescheitert. Vielleicht sollte ich ab jetzt jeden Tag da anrufen, denn das Problem führt dazu, dass wir unsere gesamte Entwicklung umstellen müssen.

Werde heute abend versuchen, eine alte Konfiguration der FB einzuspielen, vielleicht löst es das. Leider ist die schon so alt, dass ich dann einiges Nacharbeiten muss. Natürlich nicht, ohne vorher die aktuelle Konfiguration abgespeichert zu haben.

Pro-Tipp an alle Mitleser:
Vor jeder Aktion ein Backup der (funktionierenden) FB-Konfiguration speichern. Evtl kann das später Tage des Ärgers einsparen. Habe ich leider versäumt, direkt vor der Umstellung.
2020-04-07T10:39:12Z
  • Dienstag, 07.04.2020 um 12:39 Uhr

Noch ein komisches Phänomen, das in diesem Zusammenhang evtl relevant sein könnte:


An der FB kann physisch nur noch LAN1 verwendet werden, die anderen 3 Lanports bilden keinen Switch mehr.


Davor hat sich die FB wie ein Router + Switch verhalten, alle 4 Ports konnten verwendet werden.

2020-04-07T13:42:24Z
  • Dienstag, 07.04.2020 um 15:42 Uhr
Habe heute noch 2x mit dem Support telefoniert. Zuerst kam die etwas schwammige Empfehlung, ich solle "die feste IP konfigurieren". Was genau gemeint ist konnte man mir aber nicht sagen. Ich habe noch nie "eine feste IP konfiguriert".

Anscheinend gibt es einen Modus, in dem die FB nur als Modem fungiert, man müsste dann einen eigenen Router mit DHCP-Server an LAN2..4 hängen.

Beim 2. Anruf verstand der freundliche Herr sofort mein Problem und wusste, dass man das durch eine netzseitige Umkonfiguration lösen (?!?!) kann. Hat dann noch 20 Minuten und ein paar Reboots der FB gekostet. Habe jetzt nochmal eine neue IP-Adresse, aber es funktioniert so wie es war und wie es soll. Habe 110% der gekauften Speed.

Problem gelöst. Es hängt sehr davon ab, wen man im Support erwischt. Am Schluss hatte ich doch noch Glück.
2020-04-07T16:19:35Z
  • Dienstag, 07.04.2020 um 18:19 Uhr
Dann war die Fritte im BridgeMode... was eigendlich bei Business Standard ist. Zumindest mit statischer Ipv4.
2020-04-07T17:17:50Z
  • Dienstag, 07.04.2020 um 19:17 Uhr
Habe schon lange Business und statische IP und noch nie einen extra Router/DHCP-Server hinter der FB gebraucht. Habe immer das LAN und WLAN der 6490 genutzt, so wurde mir das damals auch vom freundlichen Techniker eingerichtet.

Hätte man mir seitens UM/VF mitgeteilt, dass eine solche Umstellung stattfindet und was das zur Folge hat, wäre einige Konfusion und Leerlauf vermeidbar gewesen. Hätte sogar passende Hardware und Know-How da gehabt.

Die Aussage der Vertrieblerin war aber explizit, "für Sie ändert sich nichts, ausser dass es schneller wird"...

Immerhin läuft es jetzt wieder, hoffe es bleibt so.
2020-04-07T17:40:43Z
  • Dienstag, 07.04.2020 um 19:40 Uhr
Deine feste IP wird nur noch per RIP-Mode realisiert, nicht mehr wie früher direkt in der Fritzbox.

Dateianhänge
    😄