Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Tsubasa

Server hat eine andere IPv6 als Connect Box anzeigt

Hallo liebe Community,


dadurch das meine Eltern Ihren Internetanbieter (Von IPv4 nach IPv6) gewechselt hatten, musste ich meinen Server nun über meinen eigenen Unitymedia Anschluss (IPv6) an das Internet anschließen.


Das habe ich soweit nun auch geschafft und konnte schon von außen meine Server-Webseiten aufrufen.


Nach einer weile sagte mir das Update Script für "https://dynv6.com/" plötzlich mein Server hätte die IP "XXXX:XXX:XXX:XXXX:XXXX:XXXX:XXXX:dd2e" und die Unitymedia Connect Box sagt mir unter "Verbundene Geräte" der Server hätte weiterhin die alte IP "XXXX:XXX:XXX:XXXX:XXXX:XXXX:XXXX:b82e". 

Dadurch stimmt nun aber meine "IPv6 Port Filter" nicht mehr, da diese weiterhin die alte IP eingetragen haben.


Woran kann das liegen?


Danke für eure Hilfe

Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
Dieser Beitrag wurde geschlossen.
Es ist nicht möglich, Kommentare zu schreiben. Du kannst aber jederzeit eine Frage stellen.
Frage stellen
10 Kommentare
2018-07-10T21:42:32Z
  • Dienstag, 10.07.2018 um 23:42 Uhr
Hi.
Ich nutze den gleichen Dienst und habe bisher kein Problem.
Was hast Du denn für ein Betriebssystem (bei mir ist es Linux).
Man bekommt ja bei IPv6 (wenn man es nicht ändert) 2 Adressen. Eine mit dem Präfix von UM und einer "verwurstelten" MAC Adresse als Interface und dann noch mal (wenn es nicht abgeschaltet ist) eine mit der "privacy extension".
Eventuell kommt es bei Dir da zu Verwechslungen bei laufen des Scripts, dass einmal die eine und das andere mal die andere Adresse an dynv6 über mittelt wird?

Überprüf doch mal, welche IP Adressen dein PC bekommt und ob das mit dem interface Teil der IPv6 Adresse übereinstimmt.

Mehr fällt mir auch erst mal nicht ein.


2018-07-10T21:52:15Z
  • Dienstag, 10.07.2018 um 23:52 Uhr

Hallo Tsubasa,


ich schließe mich wbier an. Schaue mal ob die privacy extensions ausgeschaltet sind. Das sollte bei einem Server gemacht werden.


Andreas

2018-07-10T22:55:34Z
  • Mittwoch, 11.07.2018 um 00:55 Uhr
Jetzt wollte ich grade nach schauen, da merke ich das die Connect Box nun die IP des Server unter "Verbundene Geräte" stehen hat.

Sollte es nochmal auftreten werde ich das mit der privacy extensions mal anschauen, trotzdem danke


Was mich jetzt aber wundert ist, dass die IPv6 Port Filter nicht auf die neue IP umgestellt wurden. Macht das die Connect Box nicht automatisch?

2018-07-11T07:27:29Z
  • Mittwoch, 11.07.2018 um 09:27 Uhr
Ich glaube nicht. Woher soll die denn wissen, dass es sich um den gleichen Rechner handelt?

Das wäre dann meiner Meinung nach ein Security Problem.


Schau mal bitte nach, welche IPv6 Adresse bei "Verbundene Geräte" genutzt wird.

Ist es die "private extension" Adresse, dann kann es sein, dass sich diese z.B. nach einem reboot  ändert.

Es sollte dort die Adresse genutt werden, die nach jedem reboot den gleichen Interface Identifier behält und das ist die, bei der die verwürfelte MAC Adresse mit drin steht (denn die ändert sich ja erst bei Tausch der Netzwerkkarte).

2018-07-12T22:04:43Z
  • Freitag, 13.07.2018 um 00:04 Uhr
Ich habe gestern die privacy extensions ausgeschaltet, die "IP Port Filter" auf die IP welche auch bei dynv6.com ankommt geändert und seit dem funktioniert es.

Die IPv6 ändert sich nun auch nicht mehr auf dem Server.


Im Router bei "Verbundene Geräte" steht aber weiterhin eine andere IPv6 Adresse, diese hat sich aber auch seit Gestern nicht mehr geändert.


Danke schon mal für eure Hilfe

2018-07-15T15:59:15Z
  • Sonntag, 15.07.2018 um 17:59 Uhr
Vorsicht! Ich weiß nicht wie das bei der Connectbox ist, aber die Privacy Extensions maximal nur für den Server deaktivieren, nicht für die anderen Geräte! 
2018-07-24T20:08:10Z
  • Dienstag, 24.07.2018 um 22:08 Uhr
@rv112:
Sorry für die späte Antwort.
Die Privacy Extensions Einstellungen ist doch eine Einstellung des Linux Servers und hat mit dem Router erstmal nichts zu tun oder verstehe ich grade etwas falsch.
2018-07-24T20:10:16Z
  • Dienstag, 24.07.2018 um 22:10 Uhr

Hallo Tsubasa
,


genau, die privacy extensions werden vom Endgerät "erzeugt" und nicht vom Router.


Andreas

2018-07-24T20:25:06Z
  • Dienstag, 24.07.2018 um 22:25 Uhr
Aber auch nur wenn SLAAC funktioniert. Für einen Serverbetrieb müssen die PE ebenfalls nicht deaktiviert werden, da der Server ja nach wie vor eine Global Scope. Die PE wird lediglich bei Outbound Anfragen verwendet und verschleiert somit die wahre IP samt MAC. 
2018-07-24T20:55:01Z
  • Dienstag, 24.07.2018 um 22:55 Uhr

Ich habe auch einen Linux Server laufen bei dem ich keine PE deaktiviert habe.

Wichtig ist nur, dass an der Box die Filterregel eben auf die IPv6 Adresse angelegt wird, die eben fest bleibt. Also von der MAC Adresse des Interfaces bestimmt wird.

Es muss also ein Adresse in der Art xxxx:xxxx:xxxx:xxxx:xxxx:xxff:fexx:xxxx sein. Das "ff" und "fe" muss an der Stelle stehen.

Ich hatte schon mal das Problem (warum auch immer) dass ich an der Fritzbox nur die PE Adresse hätte nutzen können für die Filterregel. Nach einem Reboot der Box ging es dann korrekt.

Daher nur der Hinweis, dass Tsubasa das mal kontrollieren soll, welche der IPv6 Adressen da ankommen.


Und dann hat das Script zum update des dynv6.com Eintrages bei mir die PE Adresse dort eingetragen, was dann auch nicht hilfreich war.

Das Script wird von dynv6 zur Verfügung gestellt, wenn die IPv6 Adressen aber in der "falschen" Reihenfolge gelistet werden, dann nimmt es die falsche Adresse.


In dem Script gibt es eine Abfrage mit:

address=$(ip -6 addr list scope global $device ...


Da musste ich ein "mngtmpaddr" einfügen, um die richtige Adresse zu übergeben.

address=$(ip -6 addr list scope global mngtmpaddr $device


Das nur als zusätzlichen Hinweis.