Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Diese Community verwendet Tracking-Tools Matomo zur Verbesserung des Angebots. Mit Zustimmung hilfst Du uns unsere Seite zu verbessern und akzeptieren unsere Datenschutzerklärung. Vielen Dank!   Erfahren mehr.
Zustimmen Nicht Zustimmen
utm

Verbundene Geräte erhalten nur teilweise IPv6-Adressen

Seit einigen Tagen habe ich das Problem, dass die ConnectBox von Unitymedia oft keine IPv6-Adresse an meine Geräte vergibt.

An das an den Ethernet-Port angeschlossene Raspberry Pi wird dabei immer eine IPv6-Adresse vergeben, an meine per WLAN angeschlossenen Laptops aber oft nicht. Ein Laptop erhält nahezu nie eine IPv6-Adresse, so dass ich es dutzende mal versuchen muss, bis er eine hat.

Unter "Verbundene Geräte" im Konfigurations-Interface wird als Gerätename bei diesem Laptop auch oft nicht dessen Host Name angezeigt, sondern "Unbekannt". Das passiert aber manchmal auch dann, wenn er eine IPv6-Adresse hat und per IPv6 Verbindungen aufbauen kann. Es ist aber nicht nur dieses Gerät, das nicht immer eine IPv6-Adresse bekommt. Bei diesem ist es nur besonders häufig der Fall.

Eigentlich möchte ich nur auf meinen Raspberry Pi per SSH zugreifen und die ConnectBox erlaubt mir (so weit ich das sehen kann) kein IPv4 Port Forwarding. Es hat mehrere Monate lang geklappt, dass ich auf den Raspberry PI per IPv6 zugreifen konnte, sowohl von zu Hause als auch von anderen Orten. Jetzt klappt es nur noch von anderen Orten aus zuverlässig, weil meine Laptop zu Hause oft keine IPv6-Adresse bekommen.
Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
Dieser Beitrag wurde geschlossen.
Es ist nicht möglich, Kommentare zu schreiben. Du kannst aber jederzeit eine Frage stellen.
Frage stellen
5 Kommentare
2017-10-24T11:34:03Z
  • Dienstag, 24.10.2017 um 13:34 Uhr
* an meine per WLAN angeschlossenen Laptops*
Welches Betriebsystem?, Microsoft?
2017-10-24T12:20:57Z
  • Dienstag, 24.10.2017 um 14:20 Uhr
Horst:
* an meine per WLAN angeschlossenen Laptops*
Welches Betriebsystem?, Microsoft?

Nein. Die Laptops laufen mit Ubuntu 16.04.
2017-10-24T12:52:39Z
  • Dienstag, 24.10.2017 um 14:52 Uhr
Meine Sonya bezieht immer wieder eine IPv6.Im Netzwerkmanager bei Methode steht bei IPv6-> Automatisch.Ich habe natürlich ein TC7200. Auch bei einer Knoppix keine Probleme. Du kannst da noch mal eine Live-CD probieren.Fahren die Notebooks in den Ruhezustand?

Ich würde tippen auf IPv6-Privatsphärenerweiterung(PrivacyExtension) https://www.elektronik-kompendium.de/sites/net/1601271.htm. Bei Mint ist der ausgeschaltet.

Das Phänomen tritt manchmal bei einem MX-16 auf, das ist ein Test-Netbook (mit WLan).Da ist ein OpenVpn installiert.Der ist aktviert,obwohl im Networkmanager deaktiviert. Vielleicht ist hier irgendwo ein Problem. https://wiki.ubuntuusers.de/IPv6/Privacy_Extensions/. Ich habe mich mit dem Thema noch nicht richtig beschäftigt,weil ich keine Einschränkungen habe (finde trotzdem interessant).

Ich glaube gar nicht das es an ConnectBox liegt, bzw per DHCPv6 kann man auf Stateless stellen.
https://www.elektronik-kompendium.de/sites/net/1902131.htm Hier mal probieren, der Client vergibt sich selber eine IPv6-Adresse+Mac etc. 
Hier zum Thema Stateful. http://www.elektronik-kompendium.de/sites/net/1902141.htm
Das letzte ist wirklich ein Reset durchführen, ich vermute aber das ist eine Konfigurationssache zwischen den Clients und der ConnectBox.
2017-10-24T20:33:05Z
  • Dienstag, 24.10.2017 um 22:33 Uhr
Es sind die letzte Zeit noch viel mehr gruselige Dinge im Netz passiert, das möchte ich aber nicht weiter ausführen.

Die Sache hat sich erledigt. Unitymedia ist unschuldig, die Connect Box ebenfalls (hat zwar andere Mängel, aber den hier nicht), ich bin vielleicht doch nicht verrückt, und es sind auch nicht alle meine 4 Rechner gleichzeitig ausgefallen / von einem Troll befallen worden.

Stattdessen kam ein Mitbewohner von mir auf die glorreiche Idee, einen chinesischen Repeater am anderen Ende der Wohnung (von dort aus, wo der Router steht, also am ungünstigsten nur möglichen Ort) anzuschließen. Dieser Repeater schafft es, neben seinen anderen gruseligen Aktivitäten, sämtlichen IPv6 Traffic herauszufiltern. Ist man in der Nähe des Repeaters, lässt sich, ob man über IPv6 kommunizieren kann, zuverlässig dadurch festlegen, dass man den Repeater ein- oder aussteckt. Keine Ahnung, wieso er das macht. Es ist überhaupt die vollkommen falsche Schicht. Aber er macht es.

Viele Stunden verschwendet, ich bin extrem frustriert, aber Unitymedia und die Connect Box sind wie gesagt unschuldig.
2017-10-25T03:16:59Z
  • Mittwoch, 25.10.2017 um 05:16 Uhr
Jawoll, das erinnert mich an den Bericht von SWR, mit dem China-Marderschreck auf dem Dach, wo der Luftverkehr eingeschränkt wurde. 
https://www.swr.de/swraktuell/fast-eine-million-elektrogeraete-bemaengelt/-/id=396/did=18835054/nid=396/1vii6py/index.html