Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Taphos

TL-WR841ND mit DD-WRT als Bridge an Connect Box - Internetconnect bricht ab

Hallo zusammen,

ich hoffe, zu meinem Problem gibt es noch keinen entsprechenden Thread.

Ich habe vorgestern im Rahmen eines Umzugs die neue Ausstattung mit Connectbox und Horizon-Kiste bekommen. Nach mehreren Versuchen, die Horizon-Kiste ins WLAN zu bekommen und mehreren Stunden gegoogle, habe ich feststellen müssen, dass das nicht geht und das Problem offenbar bekannt ist.


Theoretisch wäre es zwar möglich, die Kiste mit Kabel an die Connectbox anzuschließen, aber ich habe keine Lust auf ein weiteres quer durch den Raum verlegtes Kabel. Zudem würde ich gerne den Blu-ray-Player, der kein WLAN kann, auch ans Netz kriegen. Also habe ich mir gedacht, dass ich ja vielleicht meinen alten TL-WR841ND so umkonfigurieren könnte, dass der im WLAN ist und ich die beiden Geräte mit Kabel, dass dann nicht quer durch den Raum geht, anschließen kann. Das Teil also quasi als WLAN-Adapter benutzen. Nach ein bisschem weiteren gegoogle fand ich auch die Lösung. DD-WRT-Firmware drauf, als Bridge konfigurieren und fertig. Ich habe also die aktuellen DD-WRT-Images heruntergeladen, drauf gepackt und nach dieser Anleitung konfiguriert:

https://www.dd-wrt.com/wiki/index.php/Client_Bridged


So weit, so gut. Grundsätzlich funktioniert das auch. Aber: wenn ich mit Notebook (Windows 10) per Kabel an der Bridge hänge, verliert das Notebook relativ schnell die Internetverbindung. Zunächst ist Internet da, aber spätestens ab der vierten aufgerufenen Seite, ist die Verbindung weg. Die Coonectbox zeigt das Notebook als verbunden an, aber Surfen geht nicht. Wenn ich den Router stromlos mache, gleiches Verhalten: erst klappt es, dann nach ein paar Klicks im Internet nicht mehr. Die WLAN-Verbindung zwischen Router und Connectbox steht aber und selbst das Notebook sagt, dass es auf der Ethernet-Verbindung Internetconnect hat.

Was mir aufgefallen ist: das Notebook ist nicht mir der eigenenen MAC an der Connectbox sondern mit der des Ports des Routers, an dem ich hänge. Aber ob das daran liegen könnte?


Hat jemand eine Lösung dafür parat?
Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
Dieser Beitrag wurde geschlossen.
Es ist nicht möglich, Kommentare zu schreiben. Du kannst aber jederzeit eine Frage stellen.
Frage stellen
7 Kommentare
2018-05-11T06:23:32Z
  • Freitag, 11.05.2018 um 08:23 Uhr
Hi,

in deinem Artikel wird beschrieben, dass man den Modus besser nicht nutzen sollte, da er einen Hack ausnutzt und instabil ist.

Gab es seitens der proprietären Firmware deines Router nicht einen Repeater Modus? Wenn ich dich richtig verstehe, willst du das WLAN der Connect Box mit deinem TP-Link erweitern.


LG

2018-05-11T07:42:08Z
  • Freitag, 11.05.2018 um 09:42 Uhr
Danke für den Hinweis. Ich muss zugeben, dass ich mir nur durchgelesen habe, wie die Konfiguration vorzunehmen ist, weil in einem anderen Artikel, der darauf verweis, stand, dass es funktionieren würde. Nein, der TP-Link-Router hatte von Hause aus keinen entsprechenden Modus, deshalb hatte ich die andere Firmware installiert. Ich denke, ich werde dann mal einen anderen Modus als jenen, der gerade (instabil) läuft, ausprobieren.
2018-05-11T07:57:44Z
  • Freitag, 11.05.2018 um 09:57 Uhr
Evtl. gibt es ja von OpenWRT als Nachfolger noch eine aktuelle/bessere Firmware für dein Modell.

https://wiki.openwrt.org/de/toh/tp-link/tl-wr841nd


Und dann normal als Repeater. Drücke die Daumen.

2018-05-11T09:51:36Z
  • Freitag, 11.05.2018 um 11:51 Uhr
Der Horizon Recorder muss weder per LAN, noch per WLAN mit irgendeinem Router verbunden werden. Der Horizon besitzt für seine eigenen Internetdienste ein integriertes Kabelmodem, welches mit 10000/1000 provisioniert ist. Das reicht für die Dienste vom Horizon aus.

MfG
2018-05-11T09:55:13Z
  • Freitag, 11.05.2018 um 11:55 Uhr
Das mag ja sein, aber für den Zugriff auf Ressourcen im eigenen Netzwerk (Videos, Musik, Bilder) benötigt man die entsprechende Verbindung ins Netzwerk und die funktioniert bei den neueren Horizon Recordern ja nicht über WLAN.
2018-05-12T12:00:11Z
  • Samstag, 12.05.2018 um 14:00 Uhr
OpenWRT bekomme ich nicht drauf, wenn DD-WRT drauf ist, jedenfalls nicht auf Anhieb.

Das Problem scheint wohl tatsächlich daran zu liegen, dass im Client Bridge Mode nicht die MAC-Adressen der angeschlossenen Geräte erscheinen, sondern die der Switchports, an denen die Geräte hängen.

Dummerweise gibt es auch unter DD-WRT keinen Repeater Bridge Mode beim TL-WR841ND, mit dem es wohl funktionieren würde.
2018-05-12T12:13:44Z
  • Samstag, 12.05.2018 um 14:13 Uhr
Was mich in dem Zusammenhang wundert: auf die Connect Box komme ich über die Client Bridge immer, da gibt es keine Aussetzer. Nur, wenn es eben weiter ins Internet gehen soll.