Diese Website verwendet Cookies, um Dein Surferlebnis zu verbessern. Durch die weitere Nutzung der Website stimmst Du der Verwendung von Cookies zu.   Erfahre mehr.
Zustimmen
Kamairoo

Bug in Fritzbox 6590 FW 6.88 (AFTR Gateway)

Hallo zusammen,


die Firmware der FritzBox 6490 hat ab FW 6.83 einen Recht nervigen Bug.

Bei Neuverbindung (d.h. neuer IPv6 Verbindung) kann die IPv4 Verbindung über DS-Lite nicht mehr ohne manuellen Neustart hergestellt werden. Es kommt zu dem Fehler:


Internetverbindung DS-Lite ist fehlgeschlagen: Fehlergrund 2, AFTR

<Hostname> kann nicht aufgelöst werden


wobei ich den echten hostname des AFTR ersetzt habe durch <Hostname>. Dieser hängt natürlich von eurem Standort ab.


Zur Folge hat dies, dass ich, wenn ich nicht zuhause bin und die FritzBox einen Reconnect hat (gut, dass das nur 20 mal täglich vorkommt) ich nicht mehr auf die FritzBox von außen zugreifen kann bzw. meine Geräte zuhause keine Verbindung ins Internet mehr haben.


Dieser Bug wurde bereits in diversen Foren auch von Leuten, die sich eine eigene FritzBox 6490 gekauft haben reported. Es scheint wohl auf seiten AVM zu liegen und mit denen bin ich auch im Kontakt. Allerdings: In meinem Fall ist die FritzBox geliehen und damit ist Unitymedia der Verantwortliche. Aus meiner Sicht handelt es sich bei diesem Bug um einen erheblichen Mangel der sofort beseitigt werden sollte.


Kann ganz einfach reproduziert werden: Bei vorhandener Verbindung einfach in der FritzBox unter Online Monitor auf "Neu verbinden" klicken. Anschließend kommt keine Verbindung zum AFTR zu Stande und daher auch keine Verbindung ins IPv4 Netz.


Wie kann ich Vorgehen? Mangel anzeigen und Frist setzen? Downgrade verlangen (die 6.50 hatte das Problem nicht)?


Hier zum Nachlesen: 

Speichern Abbrechen
Konnte dir geholfen werden?
  • Ja
Dieser Beitrag wurde geschlossen.
Es ist nicht möglich, Kommentare zu schreiben. Du kannst aber jederzeit eine Frage stellen.
Frage stellen
9 Kommentare
2018-08-01T17:00:25Z
  • Mittwoch, 01.08.2018 um 19:00 Uhr

Falls es dir nicht aufgefallen ist: Dein Link ist über ein Jahr alt.

Der Fehler wurde in späteren Versionen behoben. Für UM war, soweit ich es in Erinnerung habe, mit 6.84 alles in Ordnung. Bei späteren Versionen (wir sind jetzt bei 6.87) liegen mir diesbezüglich keine neueren Erkenntnisse vor. Das bedeutet natürlich nicht, dass der Fehler wieder aufgetaucht ist.


Ob ein Downgrade technisch überhaupt möglich ist, weiss ich nicht. Bei der freien 6.83 wurden die entsprechenden Geräte von AVM ausgetauscht.


Wenn es nur ein DS-Lite-Problem ist, kannst du alternativ auch auf eine Umstellung auf DS pochen.


@Service-Team: könnt ihr im Titel aus 6590 eine 6490 machen?

2018-08-01T17:10:26Z
  • Mittwoch, 01.08.2018 um 19:10 Uhr
Dass der Link über einem Jahr alt ist, ist mir in der Tat aufgefallen. Der Bug besteht ja auch scheinbar schon seit 6.83. Andere Nutzer klagen über das selbe Problem mit der 6.88 (nicht 6.87, wir sind bei 6.88 jetzt): https://community.unitymedia.de/categories/hardware/article/update-fuer-die-fritz-box-6490-cable-der-rollout-der-6-88-hat-begonnen?page=33

Im offiziellen Firmware Changelog sehe ich auch keine diesbezogenen Bugfixes und die Änderung, die die Probleme wohl hervorgerufen hat ist: "ab 6.84: Aktueller Modemtreiber implementiert".

Ich kann nur sagen, dass ich den Bug mit 6.88 habe und ihn zu 100% jedes Mal reproduzieren kann per Klick auf "Neu verbinden" und er auch jedes Mal auftaucht, wenn ich einen IPv6 reconnect habe.
Mit meiner vorherigen FW (6.50) war das nicht der Fall.

Sorry für den Typo im Titel.
2018-08-01T17:32:56Z
  • Mittwoch, 01.08.2018 um 19:32 Uhr
Dummerweise kann man den Typo selbst nicht korrigieren.
Hier sind aber immer einige Praktikanten unterwegs, die die Titel manchmal bis zur Unkenntlichkeit modifizieren.

Soweit ich es in Erinnerung habe:

6.83 AFTR-Probleme bei UM aber nicht bei Vodafone/KDG

6.84 AFTR-Probleme bei UM beseitigt, jetzt tauchen sie bei Vodafone/KDG auf
Im Changelog steht dazu leider nur "Optimierte Geschwindigkeit bei Verwendung von DS-Lite"

6.85 AFTR-Probleme bei Vodafone/KDG beseitigt
Changelog "möglicher Verbindungsverlust nach IPv6-Aushandlung im Modemtreiber an speziellen Anschlüssen (Vodafone/KDG)"

Ich bin erst mit 6.87 auf eine freie Fritzbox umgestiegen und hatte zum Glück noch nie DS-lite.
Wenn ich es richtig verstanden habe, kostet dich die Umstellung auf DS lediglich 1-2 Anrufe/Chat, wenn dein aktueller Vertrag nach 2015 erfolgte.

Für mich wäre es vor allem Interessant, was AVM dazu sagt.
2018-08-01T18:04:16Z
  • Mittwoch, 01.08.2018 um 20:04 Uhr
Mhh okay. Ein richtiges DS wäre natürlich sowieso gut, da ich auch von außen aus dem IPv4 erreichbare Geräte haben möchte. Nichtsdestotrotz bietet Unitymedia das Ganze ja genauso an und ob dieser danach nicht mehr bei mir auftritt weiß ich auch nicht. Einen Versuch ist das aber vielleicht wert.
2018-08-01T21:41:14Z
  • Mittwoch, 01.08.2018 um 23:41 Uhr
Interessant, hatte jetzt gerade einen Versuch bei dem ich "Neu verbinden" geklickt habe und die FritzBox es geschafft hat die IPv4 Verbindung wieder aufzubauen.


Hab mir jetzt mal auf meinem Raspberry ein Python Script in die crontabs gesetzt welches alle 2 Minuten über TR-064 prüft ob die IPv6 Verbindung steht, aber die IPv4 Verbindung nicht und falls ja, die FritzBox rebootet. Schon ein sehr dirty workaround, aber wenigstens verbindet sich die FritzBox dann wieder wenn ich nicht zuhause bin.

2018-08-02T08:35:01Z
  • Donnerstag, 02.08.2018 um 10:35 Uhr
Neue Erkenntnisse: Der Bug tritt erst 10-15min nach Neustart auf, davor kann ich auf neu verbinden klicken und bekomme wieder eine IPv4 Verbindung.

AVM habe ich auch angeschrieben, bis lang aber keine vernünftige Aussage erhalten.

Einen echten DS habe ich gestern telefonisch beantragt, nachdem mir erst einmal erzählt wurde, dass das nur für Business Kunden geht. Der Mitarbeiter dachte wohl (was ich dann kurze Zeit später verstanden habe) ich wolle eine feste IPv4 haben. Naja, er hat irgendeinen Antrag geschrieben, ich bin mal gespannt.

2018-08-02T09:03:18Z
  • Donnerstag, 02.08.2018 um 11:03 Uhr
Wend dich an den Chat (www.unitymedia.de/kontakt - Reiter Chat & Email klicken und UBO ignorieren) oder per PM/DM an die Unitymedia Hilfe bei Facebook/Twitter und veranlasse dort die Umstellung auf DS nativ. Wenn der Hotliner das gemacht HÄTTE, wäre der DS bei dir bereits aktiv. Allerdings muss dein Vertrag bzw. Tarif von 2015 oder jünger sein!
2018-08-02T09:21:33Z
  • Donnerstag, 02.08.2018 um 11:21 Uhr
Danke für den Tipp, mein Tarif ist von 2017, sollte also gehen.
2018-08-02T17:57:45Z
  • Donnerstag, 02.08.2018 um 19:57 Uhr
Über den Chat war es tatsächlich sehr sehr einfach den DS zu bekommen. War innerhalb von wenigen Minuten freigeschaltet. Das ist denke ich der beste "Workaround" für den Bug im Moment. Mal davon abgesehen, dass mir DS Lite sowieso gegen den Strich ging, da ich auch einen Raspberry Pi als Server betreibe und bislang über einen (kostenpflichtigen) Portmapper gehen musste. Natürlich wäre im großen und ganzen ein vernüftiger, weltweiter Support für IPv6 noch besser, da ich im Prinzip ja wieder einen Schritt in die Vergangenheit damit gemacht habe, aber das ist nun wirklich nicht die Schuld von Unitymedia. Im Gegenteil, eigentlich macht Unity aus meiner Sicht alles richtig mit IPv6. Naja, wieder zurück zum Thema:

Der Bug wurde mir übrigens in der Zwischenzeit von AVM bestätigt:

"Wir konnten die Ursache des Verhaltens an einigen
Kaberlinternet-Anschlüssen, unter bestimmten Voraussetzungen, bereits
ausfindig machen und arbeiten nun an einer Lösung der Situation, welche
in einem nächsten Firmware-Update bereitgestellt wird."